Creates a new instance of this view (using specific template)
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static PanelScheduleView CreateInstanceView( Document ADoc, ElementId templateId, ElementId panelId ) |
Visual Basic |
---|
Public Shared Function CreateInstanceView ( _ ADoc As Document, _ templateId As ElementId, _ panelId As ElementId _ ) As PanelScheduleView |
Visual C++ |
---|
public: static PanelScheduleView^ CreateInstanceView( Document^ ADoc, ElementId^ templateId, ElementId^ panelId ) |
Parameters
- ADoc
- Type: Autodesk.Revit.DB..::..Document
The Document
- templateId
- Type: Autodesk.Revit.DB..::..ElementId
The templateId that this function will use
- panelId
- Type: Autodesk.Revit.DB..::..ElementId
Element id of the electrical panel element.
Return Value
The PanelScheduleView
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |