Returns the graphic overrides assigned for elements owned by a particular user.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public WorksharingDisplayGraphicSettings GetGraphicOverrides( string username ) |
Visual Basic |
---|
Public Function GetGraphicOverrides ( _ username As String _ ) As WorksharingDisplayGraphicSettings |
Visual C++ |
---|
public: WorksharingDisplayGraphicSettings^ GetGraphicOverrides( String^ username ) |
Parameters
- username
- Type: System..::..String
The username of a particular user.
Return Value
The graphic overrides assigned to this user.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This WorksharingDisplaySettings does not contain graphic overrides for the specified value of username. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |