Represents on which edges of the nosing to apply the nosing profile.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public TreadNosingPosition TreadNosingPosition { get; set; } |
Visual Basic |
---|
Public Property TreadNosingPosition As TreadNosingPosition Get Set |
Visual C++ |
---|
public: property TreadNosingPosition TreadNosingPosition { TreadNosingPosition get (); void set (TreadNosingPosition value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable. |