Identifies the start or current date and time.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public DateTime StartDateAndTime { get; set; } |
Visual Basic |
---|
Public Property StartDateAndTime As DateTime Get Set |
Visual C++ |
---|
public: property DateTime StartDateAndTime { DateTime get (); void set (DateTime value); } |
Field Value
The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.
Remarks
This property represents the start time for a single-day or multi-day study, or the current time
for a still sun study. Note that Revit may ignore this value if the SunriseToSunset flag is set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified. |