Checks whether a single username can have customized graphic overrides.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool CanUserHaveOverrides( string username ) |
Visual Basic |
---|
Public Function CanUserHaveOverrides ( _ username As String _ ) As Boolean |
Visual C++ |
---|
public: bool CanUserHaveOverrides( String^ username ) |
Parameters
- username
- Type: System..::..String
The username to check.
Return Value
False if the username is on the list of removed users, True otherwise.
Remarks
Only users that have not been removed can have overrides.
Once it is removed, a username must be restored before its associated graphic overrides
can be customized.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |