Create a new construction for Space constructions.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public MEPBuildingConstruction DuplicateConstruction( MEPBuildingConstruction pCurrentConstruction, string pName ) |
Visual Basic |
---|
Public Function DuplicateConstruction ( _ pCurrentConstruction As MEPBuildingConstruction, _ pName As String _ ) As MEPBuildingConstruction |
Visual C++ |
---|
public: MEPBuildingConstruction^ DuplicateConstruction( MEPBuildingConstruction^ pCurrentConstruction, String^ pName ) |
Parameters
- pCurrentConstruction
- Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The existing construction to be duplicated.
- pName
- Type: System..::..String
The name of the new construction.
Remarks
If the name is same with the existing one, an exception will be thrown.