Creates a free form rebar that will be unconstrained. Constraints can't be added later to this rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static Rebar CreateFreeForm( Document doc, RebarBarType barType, Element host, IList<IList<Curve>> curves, out RebarFreeFormValidationResult error ) |
Visual Basic |
---|
Public Shared Function CreateFreeForm ( _ doc As Document, _ barType As RebarBarType, _ host As Element, _ curves As IList(Of IList(Of Curve)), _ <OutAttribute> ByRef error As RebarFreeFormValidationResult _ ) As Rebar |
Visual C++ |
---|
public: static Rebar^ CreateFreeForm( Document^ doc, RebarBarType^ barType, Element^ host, IList<IList<Curve^>^>^ curves, [OutAttribute] RebarFreeFormValidationResult% error ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
A document.
- barType
- Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- host
- Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting.
- curves
- Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'Curve>)>)>>)>)>
Each array of curves represent a bar in the set.
- error
- Type: Autodesk.Revit.DB.Structure..::..RebarFreeFormValidationResult%
Will be Success if everything is ok, otherwise the failure reason.
Return Value
The newly created free form Rebar Instance.
Remarks
This function can fail due to following reasons:
- One or more of the input curves was null.
- One or more of the input curves was unbounded.
- Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |