Determines whether the given element represents an external file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool IsExternalFileReference( Document aDoc, ElementId elemId ) |
Visual Basic |
---|
Public Shared Function IsExternalFileReference ( _ aDoc As Document, _ elemId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsExternalFileReference( Document^ aDoc, ElementId^ elemId ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
A Revit Document.
- elemId
- Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for an external file reference.
Return Value
True if the given element represents an external file; false otherwise.
Remarks
CAD imports are not external file references, as their data is brought fully into Revit. No connection is maintained to the original file.
A link may be an external resource without being an external file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element elemId does not exist in the document |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |