Removes a single sweep or reveal from the compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void RemoveWallSweep( WallSweepType wallSweepType, int id ) |
Visual Basic |
---|
Public Sub RemoveWallSweep ( _ wallSweepType As WallSweepType, _ id As Integer _ ) |
Visual C++ |
---|
public: void RemoveWallSweep( WallSweepType wallSweepType, int id ) |
Parameters
- wallSweepType
- Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.
- id
- Type: System..::..Int32
The id of the sweep or reveal to remove.
Remarks
No validation of input arguments is performed. If no reveal or sweep
has the specified id, no action is performed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures. |