Reorders the sequence of Revisions in the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static void ReorderRevisionSequence( Document document, IList<ElementId> newSequence ) |
Visual Basic |
---|
Public Shared Sub ReorderRevisionSequence ( _ document As Document, _ newSequence As IList(Of ElementId) _ ) |
Visual C++ |
---|
public: static void ReorderRevisionSequence( Document^ document, IList<ElementId^>^ newSequence ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which the Revision sequence should be reordered.
- newSequence
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The new sequence of Revisions.
Remarks
This method allows the caller to change the sequence of the Revisions within the project by specifying the
new sequence. The specified sequence must include every Revision in the project exactly once.
Note that changing the sequence of Revisions can change the SequenceNumber and RevisionNumber of Revisions that have already been issued.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | newSequence does not contain every Revision exactly once. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |