Obtains a set of types that are valid for this subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public ISet<ElementId> GetValidTypes() |
Visual Basic |
---|
Public Function GetValidTypes As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetValidTypes() |
Return Value
A set of element IDs of types that are valid for this subelement or an empty set if subelement cannot have type assigned.
Remarks
A type is valid for a subelement if it can be assigned to the subelement.