Checks if the specified unit is compatible with the field description.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool CompatibleUnit( ForgeTypeId unitTypeId ) |
Visual Basic |
---|
Public Function CompatibleUnit ( _ unitTypeId As ForgeTypeId _ ) As Boolean |
Visual C++ |
---|
public: bool CompatibleUnit( ForgeTypeId^ unitTypeId ) |
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
The unit to check.
Return Value
True if the unit is compatible, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |