Gets or sets the number of items in column data array.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public int NumberOfColumns { get; set; } |
Visual Basic |
---|
Public Property NumberOfColumns As Integer Get Set |
Visual C++ |
---|
public: property int NumberOfColumns { int get (); void set (int value); } |
Remarks
Note that TableSections may use either 0 or 1 as the first row and column indices. To access the rows and columns:
- Use FirstRowNumber and LastRowNumber to get the valid range of row indices.
- Use FirstColumnNumber and LastColumnNumber to get the valid range of column indices.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections. |