Compare this object with the one supplied as argument.
Return true if the options specified by both objects are the same.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public bool IsEqualTo( DirectShapeTypeOptions other ) |
Visual Basic |
---|
Public Function IsEqualTo ( _ other As DirectShapeTypeOptions _ ) As Boolean |
Visual C++ |
---|
public: bool IsEqualTo( DirectShapeTypeOptions^ other ) |
Parameters
- other
- Type: Autodesk.Revit.DB..::..DirectShapeTypeOptions
the DirectShapeTypeOptions object to be compared.
Return Value
True if both objects specify the same options.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |