The energy model type from which gbXML will be exported.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ExportEnergyModelType ExportEnergyModelType { get; set; } |
Visual Basic |
---|
Public Property ExportEnergyModelType As ExportEnergyModelType Get Set |
Visual C++ |
---|
public: property ExportEnergyModelType ExportEnergyModelType { ExportEnergyModelType get (); void set (ExportEnergyModelType value); } |
Remarks
Default value is SpatialElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |