Represents the specific domain requirements for a system-zone used in MEP design.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public class SystemZoneData : GenericZoneDomainData |
Visual Basic |
---|
Public Class SystemZoneData _ Inherits GenericZoneDomainData |
Visual C++ |
---|
public ref class SystemZoneData : public GenericZoneDomainData |
Remarks
A system-zone is used to specify what parts of a building are served by specific equipment, air systems and water
loops without having to physically model them. A system-zone is represented as a GenericZone element with a domain
data of type SystemZoneData, which contains specific domain requirements for the purpose of analysis.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Analysis..::..GenericZoneDomainData
Autodesk.Revit.DB.Mechanical..::..SystemZoneData
Autodesk.Revit.DB.Analysis..::..GenericZoneDomainData
Autodesk.Revit.DB.Mechanical..::..SystemZoneData