The offset for the left support from the edge of the run in a horizontal direction.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double LeftLateralOffset { get; set; } |
Visual Basic |
---|
Public Property LeftLateralOffset As Double Get Set |
Visual C++ |
---|
public: property double LeftLateralOffset { double get (); void set (double value); } |
Field Value
0 if the left support is not carriage(open).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The left support style is not carriage(open), so this related data cannot be set. |