Returns a reference to the host Element face to which the RebarConstraint is attached.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.'
Will throw exception if it's a multi target constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public Reference GetTargetHostFaceReference() |
Visual Basic |
---|
Public Function GetTargetHostFaceReference As Reference |
Visual C++ |
---|
public:
Reference^ GetTargetHostFaceReference() |
Return Value
Requested reference.
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover.'
-or-
Multi target constraint. Consider using the indexed version of the method.
|
See Also