Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum AnalyticalSupportType |
Visual Basic |
---|
Public Enumeration AnalyticalSupportType |
Visual C++ |
---|
public enum class AnalyticalSupportType |
Members
Member name | Description |
---|---|
UnknownSupport | Support has not been determined. |
PointSupport | Support at just one point. |
CurveSupport | Support along a curve. |
SurfaceSupport | Support along a surface. |