Returns the top faces for this host object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static IList<Reference> GetTopFaces( HostObject hostObject ) |
Visual Basic |
---|
Public Shared Function GetTopFaces ( _ hostObject As HostObject _ ) As IList(Of Reference) |
Visual C++ |
---|
public: static IList<Reference^>^ GetTopFaces( HostObject^ hostObject ) |
Parameters
- hostObject
- Type: Autodesk.Revit.DB..::..HostObject
The host object.
Return Value
An array of references to the faces which are at the top of this element.
Remarks
This utility supports host objects whose top faces represent one of the boundaries
of CompoundStructure (such as roofs, floors or ceilings).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to top or bottom faces. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |