Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied.
If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
Parameters
- pGeomArr
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape of this object expressed as a collection of GeometryObjects.
For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType
- Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
Optional: set a view-specific shape representation that will be used in views of that type only.
Passing DirectShapeTargetViewType::Default as view type will cause the default shape to be set.
Exceptions
See Also