Interface class for external servers implementing duct fitting and duct accessory coefficient calculation.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public interface IDuctFittingAndAccessoryPressureDropServer : IExternalServer |
Visual Basic |
---|
Public Interface IDuctFittingAndAccessoryPressureDropServer _ Inherits IExternalServer |
Visual C++ |
---|
public interface class IDuctFittingAndAccessoryPressureDropServer : IExternalServer |
Remarks
A typical way to use the external server can be:
- Implement a server class that derives from this interface
- Create a new server object and register it with the service, see ExternalServiceRegistry.
- Assign server to duct fitting instance.