Rename the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void RenameCurrentType( string typeName ) |
Visual Basic |
---|
Public Sub RenameCurrentType ( _ typeName As String _ ) |
Visual C++ |
---|
public: void RenameCurrentType( String^ typeName ) |
Parameters
- typeName
- Type: System..::..String
The new name of the current family type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"typeName"-is already in use. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family type rename failed. |