Constructs text options to create text of the given type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public TextNoteOptions( ElementId typeId ) |
Visual Basic |
---|
Public Sub New ( _ typeId As ElementId _ ) |
Visual C++ |
---|
public: TextNoteOptions( ElementId^ typeId ) |
Parameters
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a text type that defines the style of a text note.
Remarks
Except for the TypeId, all other properties of the option class will be populated with their respective default values.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |