Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
Parameters
- shape
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape of this object expressed as a collection of GeometryObjects.
For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType
- Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
The view type this shape is intended for.
Return Value
True if the supplied shape passes the validation criteria.
Exceptions
See Also