The family's structural section shape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public StructuralSectionShape StructuralSectionShape { get; set; } |
Visual Basic |
---|
Public Property StructuralSectionShape As StructuralSectionShape Get Set |
Visual C++ |
---|
public: property StructuralSectionShape StructuralSectionShape { StructuralSectionShape get (); void set (StructuralSectionShape value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This Family cannot have a structural section. |