Creates a new instance of this view (using default template)
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Return Value
The PanelScheduleView
Examples
CopyC#
public void CreatePanelSchedule(UIDocument uiDocument)
{
Document doc = uiDocument.Document;
Reference selected = uiDocument.Selection.PickObject(ObjectType.Element, "Select an electrical panel");
Element panel = doc.GetElement(selected);
if (null != panel)
{
PanelScheduleView psv = null;
using (Transaction trans = new Transaction(doc, "Create a new panel schedule"))
{
trans.Start();
psv = PanelScheduleView.CreateInstanceView(doc, panel.Id);
trans.Commit();
}
if (null != psv)
{
uiDocument.ActiveView = psv;
}
else
{
TaskDialog.Show("Revit", "Please select one electrical panel.");
}
}
}
CopyVB.NET
Public Sub CreatePanelSchedule(uiDocument As UIDocument)
Dim doc As Document = uiDocument.Document
Dim selected As Reference = uiDocument.Selection.PickObject(ObjectType.Element, "Select an electrical panel")
Dim panel As Element = doc.GetElement(selected)
If panel IsNot Nothing Then
Dim psv As PanelScheduleView = Nothing
Using trans As New Transaction(doc, "Create a new panel schedule")
trans.Start()
psv = PanelScheduleView.CreateInstanceView(doc, panel.Id)
trans.Commit()
End Using
If psv IsNot Nothing Then
uiDocument.ActiveView = psv
Else
TaskDialog.Show("Revit", "Please select one electrical panel.")
End If
End If
End Sub
Exceptions
See Also