The server's method that will be called when Revit User clicks Member Forces button in the MPP.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
bool MemberForcesUpdate( MemberForcesServiceData data ) |
Visual Basic |
---|
Function MemberForcesUpdate ( _ data As MemberForcesServiceData _ ) As Boolean |
Visual C++ |
---|
bool MemberForcesUpdate( MemberForcesServiceData^ data ) |
Parameters
- data
- Type: Autodesk.Revit.DB.Structure..::..MemberForcesServiceData
The Moment Forces data.
Return Value
Indicates whether themember forces parameter server is executed successfully.
Remarks
The server provides UI way for Revit user to view and modify the detail data corresponding with the parameter value.
The server may also modify the section type parameter value itself during the execution.
The method should always return 'true' if the server is successfully executed, no matter whether the server changes anything.
Return 'false' or if the server throws, indicates a failed case, all changes made by the server will be discarded.