Retrieves a category object corresponding to the category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2016

Syntax

C#
public static Category GetCategory(
	Document document,
	ElementId categoryId
)
Visual Basic
Public Shared Function GetCategory ( _
	document As Document, _
	categoryId As ElementId _
) As Category
Visual C++
public:
static Category^ GetCategory(
	Document^ document, 
	ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
An category id.

Return Value

Returns a category object corresponding to the category id.

See Also