Retrieves the description text of the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public string GetDescriptionText() |
Visual Basic |
---|
Public Function GetDescriptionText As String |
Visual C++ |
---|
public: String^ GetDescriptionText() |
Return Value
The description text.
Remarks
Retrieved description text for built-in Revit failures is localized.
The result may vary from the description text retrieved from the corresponding FailureMessage.
A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings,
that will be used to resolve them. A FailureMessage will contain "specific" strings.
So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while
the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"