Gets the apparent load for the given phase for the given slotted circuit
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double GetApparentPhaseValue( ElementId circuitId, ElementId apparentLoadParam ) |
Visual Basic |
---|
Public Function GetApparentPhaseValue ( _ circuitId As ElementId, _ apparentLoadParam As ElementId _ ) As Double |
Visual C++ |
---|
public: double GetApparentPhaseValue( ElementId^ circuitId, ElementId^ apparentLoadParam ) |
Parameters
- circuitId
- Type: Autodesk.Revit.DB..::..ElementId
Circuit id for the apparent phase value
- apparentLoadParam
- Type: Autodesk.Revit.DB..::..ElementId
The requested apparent load phase parameter
Return Value
The value of the apparent phase
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |