Indicates if the element is a family instance with unattached voids that can cut other elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool IsVoidInstanceCuttingElement( Element element ) |
Visual Basic |
---|
Public Shared Function IsVoidInstanceCuttingElement ( _ element As Element _ ) As Boolean |
Visual C++ |
---|
public: static bool IsVoidInstanceCuttingElement( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The cutting family instance
Return Value
Returns true if the element is a family instance with unattached voids that can cut other elements.
Remarks
A family instance can cut if the family has unattached voids and the family's parameter
"Cut with Voids When Loaded" is checked.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |