Retrieves the electrical systems this electrical panel currently is assigned to.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public ISet<ElectricalSystem> GetAssignedElectricalSystems() |
Visual Basic |
---|
Public Function GetAssignedElectricalSystems As ISet(Of ElectricalSystem) |
Visual C++ |
---|
public: ISet<ElectricalSystem^>^ GetAssignedElectricalSystems() |
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created
for this model, this property will be an empty set.
This method supersedes an older AssignedElectricalSystems property which has been deprecated.