An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019.2
Syntax
C# |
---|
public OpenForeignOption OpenForeignOption { get; set; } |
Visual Basic |
---|
Public Property OpenForeignOption As OpenForeignOption Get Set |
Visual C++ |
---|
public: property OpenForeignOption OpenForeignOption { OpenForeignOption get (); void set (OpenForeignOption value); } |
Field Value
The default value is OpenForeignOption.Open.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |