This function reports any errors which were encountered
when loading the Revit links represented by the given
LinkLoadResult map.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static void ReportLinkLoadResults( Document doc, IDictionary<string, LinkLoadResult> loadResults ) |
Visual Basic |
---|
Public Shared Sub ReportLinkLoadResults ( _ doc As Document, _ loadResults As IDictionary(Of String, LinkLoadResult) _ ) |
Visual C++ |
---|
public: static void ReportLinkLoadResults( Document^ doc, IDictionary<String^, LinkLoadResult^>^ loadResults ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document containing the links.
- loadResults
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, LinkLoadResult>)>)>
A map from the display name of a link to the LinkLoadResult for that link.
Remarks
If all links succeeded in loading, the function does nothing. If any links failed to load, this function will display the Unresolved References dialog, giving the user the option to open the Manage Links dialog to correct any problems.
To ensure the dialog fits on the screen, Revit will only list up to ten link names. Additional links will be mentioned as, "And >number< additional links." This is the same behavior Revit's user interface uses.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |