Relative orientation of the right/lower and left/upper edge condition profiles.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public enum PartEdgeConditionOrientation |
Visual Basic |
---|
Public Enumeration PartEdgeConditionOrientation |
Visual C++ |
---|
public enum class PartEdgeConditionOrientation |
Members
Member name | Description |
---|---|
Complement | Before division gap is applied the left/upper and right/lower profiles coincide and neighboring panels complement each other precisely. |
Mirrored | Right/lower profile is obtained by mirroring the left/upper profile with respect to the division line. The division gap is not applied. |
MirroredAndRotated | Right/lower profile is obtained first by mirroring the left/upper profile with respect to the division line and then by mirroring the result with respect to the center line of the divided thickness. The division gap is not applied. |
Remarks
A family-based profile defines the shape of the left/upper profile and this
value defines how a matching right/lower profile is obtained.