Adds users back to the list of displayed users and permits customization of the graphics.
Any usernames that are not currently removed will be ignored.
Returns the number of users who were actually restored.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public int RestoreUsers( ICollection<string> usersToRestore ) |
Visual Basic |
---|
Public Function RestoreUsers ( _ usersToRestore As ICollection(Of String) _ ) As Integer |
Visual C++ |
---|
public: int RestoreUsers( ICollection<String^>^ usersToRestore ) |
Parameters
- usersToRestore
- Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The usernames of the users to restore. Any usernames that are not currently removed will be ignored.
Return Value
The number of usernames that were actually restored.
Remarks
This is the opposite of removing users.
Note that the user will be shown with default graphic overrides - any customizations that
existed prior to removing the user will not be restored.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |