Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( XYZ location, FamilySymbol symbol, StructuralType structuralType ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ location As XYZ, _ symbol As FamilySymbol, _ structuralType As StructuralType _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( XYZ^ location, FamilySymbol^ symbol, StructuralType structuralType ) |
Parameters
- location
- Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- structuralType
- Type: Autodesk.Revit.DB.Structure..::..StructuralType
Specify if the family instance is structural.