Sets the Layout Rule property of rebar set to Single.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void SetLayoutAsSingle() |
Visual Basic |
---|
Public Sub SetLayoutAsSingle |
Visual C++ |
---|
public: void SetLayoutAsSingle() |
Remarks
Only one bar will remain, which is at the position of rebar plane
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |