Set the layers name which user want to import into Revit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetLayerSelection( ICollection<string> layerSelection ) |
Visual Basic |
---|
Public Sub SetLayerSelection ( _ layerSelection As ICollection(Of String) _ ) |
Visual C++ |
---|
public: void SetLayerSelection( ICollection<String^>^ layerSelection ) |
Parameters
- layerSelection
- Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The layers imported into Revit.
Remarks
If user don't set any layer selection, all layers would be imported into Revit for dgn.
But for dwg|dxf, all layers (or visible layers, it is up to visibleLayersOnly was set or not) would be imported into Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |