Path to a file containing family mapping.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public string FamilyMappingFile { get; set; } |
Visual Basic |
---|
Public Property FamilyMappingFile As String Get Set |
Visual C++ |
---|
public: property String^ FamilyMappingFile { String^ get (); void set (String^ value); } |
Remarks
The file, if specified, contains data describing how to map
generic family instances to IFC containers (element types). This property
may be empty, in which case the current mapping will be used.
The default is an empty string.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |