Verifies that the user can be prompted to place the input element type interactively.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool CanPlaceElementType( ElementType elementType ) |
Visual Basic |
---|
Public Function CanPlaceElementType ( _ elementType As ElementType _ ) As Boolean |
Visual C++ |
---|
public: bool CanPlaceElementType( ElementType^ elementType ) |
Parameters
- elementType
- Type: Autodesk.Revit.DB..::..ElementType
The ElementType.
Return Value
True if the user can be prompted to place the input element type interactively, false otherwise.
Remarks
If an element type can be placed interactively, it may be used as input to PostRequestForElementTypePlacement(ElementType)
to have the user place an instance of the element. However, this function does not evaluate whether that element instance may
actually be placed in the current active view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |