Gets the user-visible name for a symbol.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static string GetLabelForSymbol( ForgeTypeId symbolTypeId ) |
Visual Basic |
---|
Public Shared Function GetLabelForSymbol ( _ symbolTypeId As ForgeTypeId _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelForSymbol( ForgeTypeId^ symbolTypeId ) |
Parameters
- symbolTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the symbol to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Symbol must have a definition. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |