Retrieve/set the base offset of the form object. It is only valid for locked form.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double BaseOffset { get; set; } |
Visual Basic |
---|
Public Property BaseOffset As Double Get Set |
Visual C++ |
---|
public: property double BaseOffset { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this is not a locked form. |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value is invalid. |
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when it fail to get/set BaseOffset. |