Indicates if the schedule includes elements from linked files.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IncludeLinkedFiles { get; set; } |
Visual Basic |
---|
Public Property IncludeLinkedFiles As Boolean Get Set |
Visual C++ |
---|
public: property bool IncludeLinkedFiles { bool get (); void set (bool value); } |
Field Value
True if elements in linked files should be included, false otherwise.
Remarks
For an embedded ScheduleDefinition, this setting is controlled
by the primary ScheduleDefinition and cannot be set in the embedded
ScheduleDefinition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleDefinition does not support including elements from linked files. -or- When setting this property: This ScheduleDefinition is an embedded ScheduleDefinition. |