Identifies the hook length for a hook type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetHookLength( ElementId hookId, double hookLength ) |
Visual Basic |
---|
Public Sub SetHookLength ( _ hookId As ElementId, _ hookLength As Double _ ) |
Visual C++ |
---|
public: void SetHookLength( ElementId^ hookId, double hookLength ) |
Parameters
- hookId
- Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
- hookLength
- Type: System..::..Double
The hook length for a hook type
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |