This function facets (i.e., triangulates) a solid or an open shell. Each boundary
component of the solid or shell is represented by a single triangulated structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static TriangulatedSolidOrShell TessellateSolidOrShell( Solid solidOrShell, SolidOrShellTessellationControls tessellationControls ) |
Visual Basic |
---|
Public Shared Function TessellateSolidOrShell ( _ solidOrShell As Solid, _ tessellationControls As SolidOrShellTessellationControls _ ) As TriangulatedSolidOrShell |
Visual C++ |
---|
public: static TriangulatedSolidOrShell^ TessellateSolidOrShell( Solid^ solidOrShell, SolidOrShellTessellationControls^ tessellationControls ) |
Parameters
- solidOrShell
- Type: Autodesk.Revit.DB..::..Solid
The solid or shell to be faceted.
- tessellationControls
- Type: Autodesk.Revit.DB..::..SolidOrShellTessellationControls
This input controls various aspects of the triangulation.
Return Value
The triangulated structures corresponding to the boundary components of the input solid or the components of the input shell.
Remarks
Every point on the triangulation of a boundary component of the solid (or
shell) should lie within the 3D distance specified by the "accuracy" input of some
point on the triangulation, and vice-versa. In some cases, this constraint may be
implemented heuristically (not rigorously).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | solidOrShell is not valid for triangulation (for example, it contains no faces). |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to triangulate the solid or shell. |