Loads the specified fabrication item files into the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public IList<FabricationItemFile> LoadItemFiles( IList<FabricationItemFile> itemFiles ) |
Visual Basic |
---|
Public Function LoadItemFiles ( _ itemFiles As IList(Of FabricationItemFile) _ ) As IList(Of FabricationItemFile) |
Visual C++ |
---|
public: IList<FabricationItemFile^>^ LoadItemFiles( IList<FabricationItemFile^>^ itemFiles ) |
Parameters
- itemFiles
- Type: System.Collections.Generic..::..IList<(Of <(<'FabricationItemFile>)>)>
The relative paths of the fabrication item files to load.
Return Value
The relative paths of the fabrication item files which failed to load.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again. -or- this operation failed. |