Gets the coordinate of a segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double GetSegmentCoordinate( int segmentId ) |
Visual Basic |
---|
Public Function GetSegmentCoordinate ( _ segmentId As Integer _ ) As Double |
Visual C++ |
---|
public: double GetSegmentCoordinate( int segmentId ) |
Parameters
- segmentId
- Type: System..::..Int32
The id of a segment in this CompoundStructure.
Return Value
The local coordinates of the specified segment.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments.
If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight].
If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from
GetRegionEnvelope(Int32).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures. |