Checks if resolution of the failures by deleting given collection of elements is permitted.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool IsElementsDeletionPermitted( IList<ElementId> idsToDelete ) |
Visual Basic |
---|
Public Function IsElementsDeletionPermitted ( _ idsToDelete As IList(Of ElementId) _ ) As Boolean |
Visual C++ |
---|
public: bool IsElementsDeletionPermitted( IList<ElementId^>^ idsToDelete ) |
Parameters
- idsToDelete
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The Ids of elements to be deleted.
Return Value
True if resolution of the failures by deleting given elements is permitted.
Remarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies
that given elements exist and can be deleted in the current state of the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |